VMware Converter 4.01 und “Visual C++”-Fehlermeldung

Wer kennt das Problem nicht? Ein Windows-System soll über den frei verfügbaren VMware Converter 4.01, den es nur in englischer Sprache gibt, in ein Datacenter “umgezogen” bzw. konvertiert werden und direkt bei der Installation kommt eine Fehlermeldung, die ein Problem mit Visual C++ beschreibt und verhindert, das der Converter-Dienst (und somit leider auch der gesamte mögliche Konvertierungsvorgang) überhaupt erst einmal startet. Die Lösung an sich ist recht subtil und einfach (wie so vieles), wenn man erst einmal das Folgende weiss:

Fehlerursache 1 kann daher rühren, das ein Temp-Verzeichnis mit Leerzeichen und / oder Umlauten gewählt ist und das mag der englische Konverter nun gar nicht – also per Rechtsklick auf “Arbeitsplatz ” plus Klicken in “Eigenschaften -> Erweitert -> Umgebungsvariablen” wechseln und die Benutzervariablen (jeweils den Wert “TEMP” und “TMP”) sowie die Systemvariablen (dito) beispielsweise auf “C:Temp” setzen – Lösungsvorschlag 1.

Fruchtet der nicht (speziell auf Serverinstallationen), so gibt es noch die Möglichkeit, eine Gruppe namens “Domain Admins” anzulegen – dies ist schlichtweg die englische Fassung der Domänen-Admins, die wir aus dem deutschen Active Directory kennen und die der VMware Converter-Dienst händeringend zum Starten sucht und benötigt. Lösungsvorschlag 2 sollte also lauten, diese Gruppe als einfache Sicherheitsgruppe anzulegen und die Converter-Installations nochmals zu versuchen – spätestens jetzt sollte der Migration dieser physischen Maschine nichts mehr im Wege stehen!

Den ganzen Artikel habe ich hier gefunden und während bei vielen das Temp-Verzeichnis die Quelle allen Übels war, so war es bei mir doch die Gruppe “Domain Admins”:

http://www.windows-faq.de/2009/11/03/vmware-converter-4-0-1-fehlermeldung-visual-c-runtime-error-1920

Einen Dank also an Michael von Windows-FAQ, der mir den letzten Denkanstoss versetzt hat und mit seinem Artikeln bereits vielen Virtualisierungswütigen die ein oder anderen unruhigen Stunden erspart hat!

2 Kommentare

  1. Nachtrag 10. 02. 2012: Fehler trat in der Zwischenzeit auch beim Converter 4.30 und 5.0 auf – bisher auffälligerweise immer unter Windows 2003 Server. Die dritte Variante wäre, bei der Fehlermeldung unter “Dienste” zu navigieren und die betreffenden Converter-Dienste von der Startberechtigung “Systemkonto” auf den jeweiligen Administrator zu setzen. Danach lassen die Dienste sich starten, die Installation nach Fehlermeldung mit “Wiederholen” auch weiterführen – fertig!

  2. Pingback: Performanceprobleme beim VMware Converter 5 | Oliver Pifferi

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*